[FIXED] Going Live -- without using the Activation Link

To Report a Bug or Problem, start a New Topic.
We'll try and resolve the problem as quickly as possible.
(New feature suggestions should be posted in "Member Suggestions" above)

Moderator: Dave Miller

[FIXED] Going Live -- without using the Activation Link

Postby sierradj » Thu Sep 02, 2004 11:44 am

DJGold allowed my listing to “go live” without me using the activation link in any welcome email.
sierradj
Active Member
Active Member
 
Posts: 27
Joined: Thu Sep 02, 2004 10:43 am
Location: Reno, NV

Re: Going Live

Postby CJ Greiner » Thu Sep 02, 2004 12:00 pm

Hi sierradj,

Thanks for bringing up this problem.

Can you describe in more detail what process you went through... and how it went live anyway?

Did you ever receive an email from DJGold with an activation link?

Had you registered on the forum prior to registering you DJ Business?

Thanks for your help with this. :idea:
>> CJ Greiner
Website Administrator

Image
www.SmithfieldEntertainment.com
www.SilverStarDJs.com
User avatar
CJ Greiner
Site Owner
Site Owner
 
Posts: 2563
Joined: Thu Nov 28, 2002 11:21 am
Location: Smithfield, VA

Re: Going Live -- without using the Activation Link

Postby sierradj » Thu Sep 02, 2004 12:16 pm

Hi CJ,

Here's all I can recall:

While in the middle of the registration process (entering my description, maybe?), I noticed that I had a capital letter in my company name (which I had filled in on a previous page!)

So I tried to hit the 'BACK' button in my browser (IE) which took me to an 'Expired Page'. I kept hitting 'BACK' until I got to the Main Registration Page and attempted to sign in there again with the same username and password. The system recognized that my username had now been already used, so I simply edited my profile and made the necessary change to my company name. It also allowed me to 'CONTINUE' where I left off in the registration process, and when I was done, the listing was live.

Hadn't even checked my email since I started entering info on the DJGold site until just now. The activation email is there, but still has not been used.

Hope that helps...

Chris
sierradj
Active Member
Active Member
 
Posts: 27
Joined: Thu Sep 02, 2004 10:43 am
Location: Reno, NV

Re: Going Live -- without using the Activation Link

Postby CJ Greiner » Thu Sep 02, 2004 12:30 pm

Hi Chris --

That DOES help.
It tells me that there's a problem somewhere in the registration coding that allowed you to login again... even though you hadn't verified your email yet.

Hmmmm... I'm going to have to dig around a little bit to see where the problem lies.
Your description of your actions will help.

Thank you.
>> CJ Greiner
Website Administrator

Image
www.SmithfieldEntertainment.com
www.SilverStarDJs.com
User avatar
CJ Greiner
Site Owner
Site Owner
 
Posts: 2563
Joined: Thu Nov 28, 2002 11:21 am
Location: Smithfield, VA

Re: Going Live -- without using the Activation Link

Postby sierradj » Thu Sep 02, 2004 12:33 pm

Just re-read my post... let me clarify something.

I tried to hit the 'BACK' button in my browser (IE) which took me to an 'Expired Page'. I kept hitting 'BACK' until I got to the Main Registration Page and attempted to sign in there again with the same username and password. BUT IT WOULDN'T LET ME CONTINUE AT THIS POINT BECAUSE THE SYSTEM RECOGNIZED THAT THIS USERNAME HAD ALREADY BEEN USED.

SO I LEFT THE REGISTRATION PAGE AND THEN EDITED MY PROFILE. That is when I edited my profile and made the necessary change to my company name. It also allowed me to 'CONTINUE' where I left off in the registration process, and when I was done, the listing was live.

Chris
sierradj
Active Member
Active Member
 
Posts: 27
Joined: Thu Sep 02, 2004 10:43 am
Location: Reno, NV

Re: Going Live -- without using the Activation Link

Postby CJ Greiner » Thu Sep 02, 2004 12:44 pm

I see...

So when you left the registration page... how did you do it?
Did you just hit the "forward" button on your browser?
Or did you follow a link?
Did you "refresh" a page in the registration process?

Thanks for the details.
>> CJ Greiner
Website Administrator

Image
www.SmithfieldEntertainment.com
www.SilverStarDJs.com
User avatar
CJ Greiner
Site Owner
Site Owner
 
Posts: 2563
Joined: Thu Nov 28, 2002 11:21 am
Location: Smithfield, VA

Re: Going Live -- without using the Activation Link

Postby sierradj » Thu Sep 02, 2004 1:04 pm

Definitely didn't hit the "forward" button on the browser.
Definitely didn't "refresh" a page in the registration process.

I clicked a link at the top of whatever page I was on that either said 'Edit Profile' or View Profile'.

Chris
sierradj
Active Member
Active Member
 
Posts: 27
Joined: Thu Sep 02, 2004 10:43 am
Location: Reno, NV

Re: Going Live -- without using the Activation Link

Postby tester3 » Thu Sep 02, 2004 4:10 pm

Okay... I was able to duplicate the problem.

Now I just have to figure out how to fix it!

Thanks.

--------------
» CJ Greiner

DJGold.com
Website Administrator
tester3
 

Re: Going Live -- without using the Activation Link

Postby CJ Greiner » Thu Sep 02, 2004 6:32 pm

Well... I think I found it.

I've written all the code for the search engine, but I rely on phpBB to work as the backend for the Discussion Forum (No need to reinvent the wheel!)

When you mentioned that you clicked on one of the "Edit Profile" links... that gave me the clue.

For some strange reason, the phpBB programmers "assumed" that if someone was logged in and was accessing the "Edit Profile" program... that they MUST also have validated their email. So when you clicked on "enter" or "update" in the "Edit Profile" page--it also changed your status to "validated."

As you found out, that's not always correct.

I don't know if there are other holes in the phpBB program, but I did find a way to patch up that one. Now, if someone clicks on that link and their email hasn't been validated, then they're just redirected back to the main page.

Thanks for helping out with the troubleshooting. :lol:
>> CJ Greiner
Website Administrator

Image
www.SmithfieldEntertainment.com
www.SilverStarDJs.com
User avatar
CJ Greiner
Site Owner
Site Owner
 
Posts: 2563
Joined: Thu Nov 28, 2002 11:21 am
Location: Smithfield, VA


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron